QuickCliq - Card transactions impacted

Incident Report for Sentral

Resolved

The issue impacting card transactions has been resolved, and services are now operating normally. Card transactions are processing successfully.
Posted Jul 24, 2026 - 22:23 AEST

Monitoring

The issue impacting card transactions has now been resolved, and transactions are processing successfully.

Our team will continue to closely monitor the service to ensure stability and confirm that all systems are operating as expected.

Thank you for your patience and understanding while we worked to restore service. We will provide a further update once monitoring is complete.
Posted Jul 24, 2026 - 09:27 AEST

Identified

We are currently experiencing a critical issue impacting card transactions. Please add credit if you can via PayPal, we aim to have this issue resolved as soon as possible. Thank you for your patience
Posted Jul 24, 2026 - 09:06 AEST